purestorage.flasharray.purefa_messages module – List FlashArray Alert Messages

Note

This module is part of the purestorage.flasharray collection (version 1.16.2).

You might already have this collection installed if you are using the ansible package. It is not included in ansible-core. To check whether it is installed, run ansible-galaxy collection list.

To install it, use: ansible-galaxy collection install purestorage.flasharray. You need further requirements to be able to use this module, see Requirements for details.

To use it in a playbook, specify: purestorage.flasharray.purefa_messages.

New in purestorage.flasharray 1.14.0

Synopsis

  • List Alert messages based on filters provided

Requirements

The below requirements are needed on the host that executes this module.

  • python >= 3.3

  • purestorage >= 1.19

  • py-pure-client >= 1.26.0

  • netaddr

  • requests

  • pycountry

  • packaging

Parameters

Parameter

Comments

api_token

string

FlashArray API token for admin privileged user.

fa_url

string

FlashArray management IPv4 address or Hostname.

flagged

boolean

Show alerts that have been acknowledged or not

Choices:

  • false ← (default)

  • true

history

string

Historical time period to show alerts for, from present time

Allowed time period are hour(h), day(d), week(w) and year(y)

Default: "1w"

severity

list / elements=string

severity of the alerts to show

Choices:

  • "all" ← (default)

  • "critical"

  • "warning"

  • "info"

Default: ["all"]

state

string

State of alerts to show

Choices:

  • "all"

  • "open" ← (default)

  • "closed"

Notes

Note

  • This module requires the purestorage and py-pure-client Python libraries

  • Additional Python librarues may be required for specific modules.

  • You must set PUREFA_URL and PUREFA_API environment variables if fa_url and api_token arguments are not passed to the module directly

Examples

- name: Show critical alerts from past 4 weeks that haven't been acknowledged
  purefa_messages:
    history: 4w
    flagged : False
    severity:
    - critical
    fa_url: 10.10.10.2
    api_token: 89a9356f-c203-d263-8a89-c229486a13ba

Authors

  • Pure Storage Ansible Team (@sdodsley)