Documentation

4. 要件

注釈

Tower は総合的なアプリケーションで、インストールプロセスでは PostgreSQL、Django、NGINX など、複数の依存関係をインストールします。スタンドアロンの仮想マシンまたはクラウドインスタンスに Tower をインストールし、そのマシンに別のアプリケーションを共存させることはできません (モニタリングまたはロギングソフトウェア以外)。Tower および Ansible は Python で記述されていますが、単純な Python ライブラリーではありません。そのため、Tower は Python virtualenv や類似したサブシステムにはインストールできません。本ガイドのインストールの方法に記載されているようにインストールする必要があります。OpenShift ベースのデプロイメントについては、「OpenShift Deployment and Configuration」を参照してください。

Ansible Tower には以下の要件があります。

  • サポート対象のオペレーティングシステム:

    • Red Hat Enterprise Linux 8.0 以降 64 ビット (Ansible Tower 3.5 以降のバージョンのみインストール可能)
    • Red Hat Enterprise Linux 7.4 以降 64 ビット
    • CentOS 7.4 以降 64 ビット
    • Ubuntu 16.04 LTS 64 ビット (Ubuntu のサポートは非推奨になり、今後のリリースで削除予定です)

注釈

Tower のプラットフォームとしての Ubuntu 14.04 のサポートは、Ansible Tower バージョン 3.4 で削除されました。

  • Mozilla Firefox または Google Chrome の現行のサポートバージョン

    • その他の HTML 5 準拠の Web ブラウザーは機能する場合がありますが、完全にテストまたはサポートされていません。
  • Tower のインストールには、最低でも CPU が 2 つ 必要です。特定の設定でのフォーク数に必要とされる CPU の容量を判断するには、『 Ansible Tower User Guide 』の「capacity algorithm」のセクションを参照してください。

  • 最小 4 GB のメモリー *(Tower のインストール)

    • 4 GB のメモリー (Vagrant 試用版のインストールには推奨最小要件)
    • 4 GB メモリー (外部のスタンドアロン Postgres データベースには最小要件)
    • 固有のメモリー要件については、『 Ansible Tower User Guide 』の「ref:capacity algorithm <userguide:ug_job_concurrency>」セクションを参照して、特定の設定でのフォーク数に必要とされる容量を判断してください。
  • Tower サービスモード専用の ハードディスク容量 20 GB

    • 要件 20 GB 中で /var/ 専用に 10 GB 分割り当てる必要があります。/var/ は Tower がファイルおよび作業ディレクトリーを保存する場所です。
    • ストレージボリュームは、最低ベースラインとして IOPS が 750 となるようにする必要があります。
  • データベースを含むノード専用の ハードディスク容量 20 GB (150 GB 以上を推奨)

    • ストレージボリュームは、ベースライン IOPS (1000 以上) を高くする必要があります。
    • Tower データはすべてデータベースに格納されます。データベースストレージは、管理するホスト、実行するジョブ数、ファクトキャッシュに保存するファクト数、個別ジョブのタスク数に合わせて増加します。たとえば、ホスト 250 台とタスク 20 件に対して 1 時間毎 (1 日に 24 回) に実行される Playbook は毎週データベースに 80 万件以上のイベントを保存します。
    • データベースに十分な容量が確保されていない場合には、以前のジョブ実行やファクトを定期的に消去する必要があります。詳しい情報は、『 Ansible Tower User Guide 』の「Management Jobs」を参照してください。
  • 64 ビットのサポートが必要 (カーネルとランタイム)

  • |at| 3.2 以降を実行するには PostgreSQL バージョン 9.6.X が必要

  • |at| バージョン 3.2 以降を実行するには (最低でも) Ansible バージョン 2.2 が必要

注釈

上記に指定した PostgreSQL のバージョンと Ansible のバージョンよりも古いバージョンを使用して、Ansible Tower 3.2 以降を実行できません。PostgresSQL も Ansible も存在しない場合には、インストールスクリプトでインストールされます。

  • Amazon EC2 の場合:

    • インスタンスのサイズは m4.large 以上
    • ホスト 100 台以上ある場合には m4.xlarge 以上

4.1. Tower の要件に関する追加の注意点

他のオペレーティングシステムは技術的に機能する場合がありますが、現在 Ansible Tower インストールのホストをサポートするのは上記の一覧のみです。サポートのないオペレーティングシステムで Tower を実行するという確実な要件がある場合には Red Hat カスタマーポータル (https://access.redhat.com/) 経由で Ansible までお問い合わせください。他のオペレーティングシステム (ノード) の管理は、Ansible プロジェクト自体に文書でまとめられており、リストに追加することも可能です。

実際のメモリー要件は Tower が同時に管理するホスト数により異なります (これはジョブテンプレートまたはシステムの ansible.cfg ファイルの forks パラメーターにより制御されています)。発生する可能性のあるリソースの競合を回避するには、Ansible はフォーク 100 ごとにメモリー 1 GB を、さらに Tower 用に + 2GB 分搭載することを推奨しています。詳細は「 capacity algorithm」を参照してください。forks を 400 に設定した場合には、メモリー 40 GB を搭載することを推奨します。

Ansible Tower をインストールするホストでは、Tower により、umask=0022 が 0022 に設定されているかどうかが確認されます。設定に失敗する場合は、 に設定してこのエラーが発生しないようにしてください。

当然、より多くのホストに対応できますが、フォーク数がホストの総数より少ない場合は、ホスト間により多くのパスが必要です。設定を要求する各システムがキューに入り、できるだけ早く処理されるか、あるいは Tower が AMI などのイメージを作成またはデプロイする場合など、定期的な更新の使用、または Tower に含まれるプロビジョニングコールバックシステムを使用して、このようなメモリーの制限を回避することができます。これらすべては、大規模な環境を管理する優れたアプローチです。他に質問がある場合には、Red Hat カスタマーポータル (https://access.redhat.com) 経由で Ansible までお問い合わせください。

Tower が管理するシステムの要件は Ansible と同じです (http://docs.ansible.com/intro_getting_started.html)。

4.2. Ansible のソフトウェア要件

Ansible Tower は Ansible Playbook に依存しており、インストール前に Ansible の最新安定版をインストールする必要がありますが、手動で Ansible をインストールする必要はなくなりました。

Ansible Tower バージョン 2.3 以降、Tower のインストールプログラムはインストールプロセスの一部として Ansible のインストールを試行します。以前の Tower では、Tower のインストールプログラムを実行する前に Ansible ソフトウェアリリースパッケージを手動でインストールする必要がありました。現在は Tower は、最新安定版の Ansible リリースパッケージのインストールを試行します。

バンドルの Tower インストールを実行する場合は、インストールプログラムにより、バンドルから Ansible およびその依存関係のインストールが試行されます (詳しい情報は「バンドルの Tower インストールプログラムの使用」を参照してください)。

Ansible をご自身でインストールすることにした場合には、Tower インストールプログラムは Ansible がインストールされていることを検出して、再インストールを試行しないようにします。Ansible Tower が正しく機能するようにするには、yum などのパッケージマネージャーを使用して Ansible をインストールし、最新安定版をインストールする必要がある点に注意してください。Ansible Tower バージョン 3.2 以降には、Ansible バージョン 2.2 が最小限必要です。