ansible.netcommon.enable – Switch to elevated permissions on a network device

Note

This plugin is part of the ansible.netcommon collection (version 2.5.0).

You might already have this collection installed if you are using the ansible package. It is not included in ansible-core. To check whether it is installed, run ansible-galaxy collection list.

To install it, use: ansible-galaxy collection install ansible.netcommon.

To use it in a playbook, specify: ansible.netcommon.enable.

New in version 1.0.0: of ansible.netcommon

Synopsis

  • This become plugins allows elevated permissions on a remote network device.

Parameters

Parameter Choices/Defaults Configuration Comments
become_pass
string
ini entries:

[enable_become_plugin]
password = None

env:ANSIBLE_BECOME_PASS
env:ANSIBLE_ENABLE_PASS
var: ansible_become_password
var: ansible_become_pass
var: ansible_enable_pass
password

Notes

Note

  • enable is really implemented in the network connection handler and as such can only be used with network connections.

  • This plugin ignores the ‘become_exe’ and ‘become_user’ settings as it uses an API and not an executable.

Authors

  • Ansible Networking Team