community.grafana.grafana_plugin module – Manage Grafana plugins via grafana-cli

Note

This module is part of the community.grafana collection (version 1.5.2).

You might already have this collection installed if you are using the ansible package. It is not included in ansible-core. To check whether it is installed, run ansible-galaxy collection list.

To install it, use: ansible-galaxy collection install community.grafana.

To use it in a playbook, specify: community.grafana.grafana_plugin.

Synopsis

Parameters

Parameter

Comments

grafana_plugin_url

string

Full URL to the plugin zip file instead of downloading the file from https://grafana.com/api/plugins.

Requires grafana 4.6.x or later.

grafana_plugins_dir

string

Directory where the Grafana plugin will be installed.

If omitted, defaults to /var/lib/grafana/plugins.

grafana_repo

string

URL to the Grafana plugin repository.

If omitted, grafana-cli will use the default value: https://grafana.com/api/plugins.

name

string / required

Name of the plugin.

state

string

Whether the plugin should be installed.

Choices:

  • present ← (default)

  • absent

version

string

Version of the plugin to install.

Defaults to latest.

Examples

---
- name: Install/update Grafana piechart panel plugin
  community.grafana.grafana_plugin:
    name: grafana-piechart-panel
    version: latest
    state: present

Return Values

Common return values are documented here, the following are the fields unique to this module:

Key

Description

version

string

version of the installed/removed/updated plugin.

Returned: always

Authors

  • Thierry Sallé (@seuf)