netapp_eseries.santricity.na_santricity_firmware module – NetApp E-Series manage firmware.

Note

This module is part of the netapp_eseries.santricity collection (version 1.3.1).

You might already have this collection installed if you are using the ansible package. It is not included in ansible-core. To check whether it is installed, run ansible-galaxy collection list.

To install it, use: ansible-galaxy collection install netapp_eseries.santricity.

To use it in a playbook, specify: netapp_eseries.santricity.na_santricity_firmware.

Synopsis

  • Ensure specific firmware versions are activated on E-Series storage system.

Parameters

Parameter

Comments

api_password

string / required

The password to authenticate with the SANtricity Web Services Proxy or Embedded Web Services API.

api_url

string / required

The url to the SANtricity Web Services Proxy or Embedded Web Services API.

Example https://prod-1.wahoo.acme.com:8443/devmgr/v2

api_username

string / required

The username to authenticate with the SANtricity Web Services Proxy or Embedded Web Services API.

clear_mel_events

boolean

This flag will force firmware to be activated in spite of the storage system mel-event issues.

Warning! This will clear all storage system mel-events. Use at your own risk!

Choices:

  • no ← (default)

  • yes

firmware

string / required

Path to the firmware file.

Due to concurrency issues, use M(na_santricity_proxy_firmware_upload) to upload firmware and nvsram to SANtricity Web Services Proxy when upgrading multiple systems at the same time on the same instance of the proxy.

nvsram

string

Path to the NVSRAM file.

NetApp recommends upgrading the NVSRAM when upgrading firmware.

Due to concurrency issues, use M(na_santricity_proxy_firmware_upload) to upload firmware and nvsram to SANtricity Web Services Proxy when upgrading multiple systems at the same time on the same instance of the proxy.

ssid

string

The ID of the array to manage. This value must be unique for each array.

Default: 1

validate_certs

boolean

Should https certificates be validated?

Choices:

  • no

  • yes ← (default)

wait_for_completion

boolean

This flag will cause module to wait for any upgrade actions to complete.

When changes are required to both firmware and nvsram and task is executed against SANtricity Web Services Proxy, the firmware will have to complete before nvsram can be installed.

Choices:

  • no ← (default)

  • yes

Notes

Note

  • The E-Series Ansible modules require either an instance of the Web Services Proxy (WSP), to be available to manage the storage-system, or an E-Series storage-system that supports the Embedded Web Services API.

  • Embedded Web Services is currently available on the E2800, E5700, EF570, and newer hardware models.

  • M(netapp_e_storage_system) may be utilized for configuring the systems managed by a WSP instance.

Examples

- name: Ensure correct firmware versions
  na_santricity_firmware:
    ssid: "1"
    api_url: "https://192.168.1.100:8443/devmgr/v2"
    api_username: "admin"
    api_password: "adminpass"
    validate_certs: true
    nvsram: "path/to/nvsram"
    firmware: "path/to/bundle"
    wait_for_completion: true
    clear_mel_events: true
- name: Ensure correct firmware versions
  na_santricity_firmware:
    ssid: "1"
    api_url: "https://192.168.1.100:8443/devmgr/v2"
    api_username: "admin"
    api_password: "adminpass"
    validate_certs: true
    nvsram: "path/to/nvsram"
    firmware: "path/to/firmware"

Return Values

Common return values are documented here, the following are the fields unique to this module:

Key

Description

msg

string

Status and version of firmware and NVSRAM.

Returned: always

Authors

  • Nathan Swartz (@ndswartz)