purestorage.flasharray.purefa_hardware module – Manage FlashArray Hardware Identification

Note

This module is part of the purestorage.flasharray collection (version 1.26.0).

You might already have this collection installed if you are using the ansible package. It is not included in ansible-core. To check whether it is installed, run ansible-galaxy collection list.

To install it, use: ansible-galaxy collection install purestorage.flasharray. You need further requirements to be able to use this module, see Requirements for details.

To use it in a playbook, specify: purestorage.flasharray.purefa_hardware.

New in purestorage.flasharray 1.24.0

Synopsis

  • Enable or disable FlashArray visual identification lights

Requirements

The below requirements are needed on the host that executes this module.

  • python >= 3.3

  • purestorage >= 1.19

  • py-pure-client >= 1.26.0

  • netaddr

  • requests

  • pycountry

Parameters

Parameter

Comments

api_token

string

FlashArray API token for admin privileged user.

enabled

boolean

State of the component identification LED

Choices:

  • false

  • true

fa_url

string

FlashArray management IPv4 address or Hostname.

name

string / required

Name of hardware component

Notes

Note

  • This module requires the purestorage and py-pure-client Python libraries

  • Additional Python librarues may be required for specific modules.

  • You must set PUREFA_URL and PUREFA_API environment variables if fa_url and api_token arguments are not passed to the module directly

Examples

- name: Enable identification LED
  purestorage.flasharray.purefa_hardware:
    name: "CH1.FB1"
    enabled: True
    fa_url: 10.10.10.2
    api_token: T-68618f31-0c9e-4e57-aa44-5306a2cf10e3

- name: Disable identification LED
  purestorage.flasharray.purefa_hardware:
    name: "CH1.FB1"
    enabled: False
    fa_url: 10.10.10.2
    api_token: T-68618f31-0c9e-4e57-aa44-5306a2cf10e3

Authors

  • Pure Storage Ansible Team (@sdodsley)